How can we improve SQL Source Control?

TFS Migration script unusable with custom port

When clicking the "Add a Migration Script" link on the Commit Changes tab, the TFS url and port are read only. As we use TFS on port 80 instead of port 8080, we cannot use this feature.

The same applies when setting up the link on the Setup tab.

0 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    philcartphilcart shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    started  ·  StephanieAdminStephanie (Admin, Red Gate) responded  · 

    We have been working on v2 of Migrations, which no longer requires a separate migrations location to be specified when linking. An Early Access Release of SQL Source Control is now available and can be downloaded from http://documentation.red-gate.com/display/MV2.

    NOTE: This is an Early Access Release and is not fully tested or functionally complete yet. It would be great if you could try it in a test environment and let us know about your experiences so we can fix any issues and try to make any updates you need before the full release.

    Thank you!
    Stephanie Herr :-)
    SQL Source Control Product Manager

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Jeff FosterAdminJeff Foster (Admin, Red Gate) commented  ·   ·  Flag as inappropriate

        In the next release (which'll hopefully be available shortly via the Check For Updates mechanism), we have improved the way that TFS ports are handled. We no longer split the URL into host / port, instead requiring a URL to give the port details if it differs from the default. In your case, it sounds like you'll just need to specify the URL as http://yourserver/yourpath and we'll now do the right thing.

      • Chris SmithAdminChris Smith (Project Manager - SQL Lighthouse, Red Gate) commented  ·   ·  Flag as inappropriate

        Hi

        I'm afraid you will need to unlink and re-link your database from source control to be able to update the Migration Script URL to include a port number.

        When re-linking the database to the schema repository, the migrations folder url field should also be enabled. You can then include the port number in the url.

        We hope to add the ability to edit repository URLS (including Migrations Script location) in the future.

        Best regards,
        Chris

      • philcartphilcart commented  ·   ·  Flag as inappropriate

        Ok, using Win 7 64bit. SSC v3.0.4.24 & SSMS 10.5.2500.0

        My database is linked to TFS and I can check items in, etc... Migrations folder is not setup.

        Clicking "Setup Link" for the migrations folder BOTH the url and port are read only.

        Very disappointed that this port issue still exists in the product as I had raised this as an issue FIVE months ago (ref SOC-3044).

      • Chris SmithAdminChris Smith (Project Manager - SQL Lighthouse, Red Gate) commented  ·   ·  Flag as inappropriate

        I believe there is a workaround for this; you can specify a port in the Migration Scripts repository URL field. For instance to specify port 8081 I would add the following:

        "http://my-tfs-2010rtm.mydomain.com:8081/tfs/sqlsourcecontrolcollection";

        If you have already connected to a Migration Script location but against the wrong port, you will need to unlink and re-link your database from source control to be able to edit the Migration Script URL.

      Feedback and Knowledge Base