How can we improve SQL Source Control?

Vault 6

Support Vault Server version 6.0 that came out recently. Currently when trying to connect against that version, SSC responds with an error of "unsupported server version". It would be nice to make SSC 3.x work with Vault 6.x.

11 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Marc-AndreMarc-Andre shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    10 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • GregGreg commented  ·   ·  Flag as inappropriate

        Ok, with a tip from another user I unlinked my databases and relinked. Now it is working with Vault 6.1 and SQL Source Control 3.4.0.103!

        I know I've tried this many times in the past, so not sure what version fixed this. I swear I had tried v3.2 as well.

      • GregGreg commented  ·   ·  Flag as inappropriate

        Why is the marked Completed? As of SQL Source Control v3.4.0.103 we still cannot access Vault 6.1. It worked with 6.0, but the upgrade to 6.1 broke it.

      • Steve GSteve G commented  ·   ·  Flag as inappropriate

        I am running SQL Source Control 3.3.1.30
        Source Gear Vault Server is 6.1.0
        Source Gear Client is 6.1.0 (531) - Although i doubt the client app matters

        and SQL Source is throwing the error "Server edition is correct, but the version is wrong"

        I'm not sure what "version" is wrong

      • Scott KuhnScott Kuhn commented  ·   ·  Flag as inappropriate

        Is there any update on this? Any guidance as to when we might expect support for Vault 6.0 in the RedGate tools. (Specifical SQL Source Control and SQL Compare)

      • Tom HighfieldTom Highfield commented  ·   ·  Flag as inappropriate

        Upgrading to Vault 6.0 is required for use with Visual Studio, so it would indeed be important for redgate to support that version of Vault without clumsy workarounds.

      • David AtkinsonAdminDavid Atkinson (Admin, Red Gate) commented  ·   ·  Flag as inappropriate

        The intent was for us to support it from the outset, but we somehow missed the Vault 6 release. Sorry! However, we're actively working on this now and we'll hopefully have a fix real soon (I'm hoping days).

      Feedback and Knowledge Base